Support
Support

000051 : Logon to Sage failed – Error 31, SDO not registered

Created: 11 Aug 2007
Last Updated: 20 Oct 2016

Message

Logon to Sage failed.

Error 31: The SDO has not been registered on this machine or the registration may have ‘timed out’. Please use the Enable 3rd Party Integration feature in Sage to register Sage Data Objects. See the Sage User Guide or ConnectIt FAQ for further information on Enabling 3rd Party Integration.
Message Image

Cause

Sage Data Objects are not registered and Third Party Integration has not been enabled.

Note: this is a very common problem after a user has been using the ConnectIt software for some time; the Sage Data Objects registration appears to “time out” after a period of time and this is (unfortunately) out of our control.

Resolution

1. Register Sage Data Objects and enable Third Party Integration on your Sage accounts.

2. To do this, open Sage and click the Tools | Activation | Enable Third Party Integration menu option.

3. A screen will appear with a phone number to call; request the SDO Serial Number and Activation Key from the Sage customer services agent, enter the details in the textboxes provided and click the Register button.

Note: when calling the phone number the Sage customer services agent will usually ask you for you Sage Line 50 Serial Number (see the Help | About menu for this), your company name, first line of your address and / or postcode. Attaining the SDO Serial Number and Activation Key is a completely free service (apart from the price of the call) and will typically take no long than 5 minutes.

No details need to be changed with respect to the ConnectIt configuration; once the SDO is re-registered then ConnectIt will work as before.

Additional: in some instances we have known for the SDO to be registered on a PC, but ConnectIt to still display a message that it cannot connect. This was in a multi-user environment when the SDO had only been registered on one user’s PC. By registering the SDO on all users PCs, then ConnectIt was able to connect to the Sage data files.

Video


Search Again

See Also...

ID Article TitleLast Updated
000003 ConnectIt-Sage50 Step-by-Step Guide to Configuration 10 Oct 2018

l: 0844 357 7360 | i: +44(0)1273 013695 | e: enquiries@hilltopsit.co.uk
© Hilltops IT Consultancy Services Ltd 2005-2023

Time saving solutions from Hilltops IT